vSAN Deployment Issues with Cluster Quickstart

I ran into some gotchas when deploying a vSAN 6.7 U1 cluster. The cluster quickstart should save time when deploying a vSAN cluster. However, there are a couple steps to take to avoid issues.

Do not use the vSphere Flash client for any step on the deployment. Only use the vSphere HTML5 client. There are odd issues that can occur. For example, I created the cluster in the Flash client. I then wanted to run quickstart in the HTML5 client. However, the options were grayed out under cluster basics so I could not select anything or go to add hosts. I deleted the cluster and created it in the HTML5 client. Then quickstart worked fine. I later had another new deployment. I tried out the same scenario and had the same problem.

quickstart1

Quickstart has the option of creating a vDS. The vDS will be created at version 6.5. There is no option to select a specific version of the vDS when deployed through quickstart. This is fine depending on the other versions of vDSs in your environment and if maintaining vMotion compatibility is a requirement.  For example, if another cluster has a vDS on version 6.0, then VMs in that cluster cannot be live migrated to the vSAN cluster on vDS version 6.5 since different vDS versions. Only option is to power off the VM to allow it to be migrated. To get around this, create a vDS on version 6.0 before starting quickstart. Then select the option to ‘USE EXISTING’ on the distributed switches section of quickstart.

quickstart2

Quickstart is definitely very useful and can save a lot of time if not hitting these gotchas. The ability to auto-fill sequential IP addresses for management and vMotion, and ESXi root login credentials are convenient. Hopefully, fault tolerance will eventually be added to quickstart. Also, having a guided workflow makes the vSAN deployment relativity easy.